
SPS Support Structure 
How to generate log files

Farzad Hamzepour
SPS Service & Support Vienna

April 28, 2015



The main purpose of this document is to let our partners know how to generate log files and at the 
main time, remind them what is the current SPS support structure.
As you know, more information makes the analysis process of the support request faster, more efficient 
and save our time, so please mention the request of these information mandatory while sending this 
document to the partner.
Please don't hesitate to contact us for any missing part regarding “How to generate log files”.
They can communicate/attach the following information while creating a ticket:
- Step by step description of the issue
- OS version
- Philips software version
- Device name + FW version
- If virtualization is involved (WTS/Citrix/VMWare): OS versions (Client/Target) + extensions version + 

PSPDistpacher.log
- The exact time of the occurred error + log file + Windows Event log (Right click on "Applications" 

and "System" and "Save All Events As ... .evtx " under: Control Panel> System and Security> 
Administrative Tools> Event Viewer> Windows Logs)

- If the error is reproducible (or not): the log files always in DEBUG mode + screenshot (if 
reproducible)

- MSInfo32
- If the issue is related to a dictation: the dictation file
- If the DNS is in use: the DNS version + the dictation(s) + .rtf + DNS user profile + DNS log file 
- If a remote session was made: The video of this remote session



How to generate log files? 



SpeechExec: SE, SEP, SEE
Setting Debug Mode:
1- Close SpeechExec software
2- locate the installation folder of SpeechExec Pro/Enterprise Dictate/Transcribe
Typically: C:\Program Files (x86)\Philips Speech\SpeechExec Pro/Enterprise Dictate/Transcribe
3- Launch SpeechExecLogTool.exe
4- In the box for 'Select application'...make sure SEPDict/Trans is shown/selected
For debugging we will only work with the components within the 'SpeechExec components' TAB
5- Set the 'log level' of each listed component from 'Error' to 'Debug'. You do this by hovering over each edit box where a drop-list button will appear
6- Once all components have been set to 'Debug' click 'Apply'...you receive a warning that no SpeechExec Application should be running before you click 
'OK'...click OK
In a few seconds the logging tool has prepared the system to debug the application.
7- Click 'Close' on the tool
8- Edit the file SpeechExecLog.config (with Notepad)
SE and SEP: Change the MaximumFileSize value from "10MB" to "999MB" and save the changes 
SEE: Change the MaximumFileSize value from "100MB" to "999MB" and save the changes *** 

Run SpeechExec until you receive the error message or are able to reproduce the reported issue and then close the application.

Collecting the resulting log files:
1- Locate the 'Logging' folder.
The log file location is typically C:\Users\<current_user>\AppData\Roaming\Philips Speech\SpeechExec\Logging (click Start or go to the Windows 8 Search or 
at the Window’s Address bar, type %appdata% and hit Enter)
2- Compress the 'Logging' ...right-click -> 'send to' -> compressed folder
3- Attach the result 'logging.zip' to the ticket

Turning off 'Debug' mode, please ensure this is done, as the application will run more slowly.
1- locate the installation folder of SpeechExec Pro/Enterprise Dictate/Transcribe
Typically: C:\Program Files (x86)\Philips Speech\SpeechExec Pro/Enterprise Dictate/Transcribe
2- Launch SpeechExecLogTool.exe
3- In the box for 'Select application'...make sure SEPDict/Trans is shown/selected
4- Set the 'log level' of each listed component from 'Debug' to 'Error'. You do this by hovering over each edit box where a drop-list button will appear
5- Once all components have been set to 'Error' click 'Apply'...you receive a warning that no SpeechExec Application should be running before you click 
'OK'...click OK
6- Click 'Close' on the tool

*** In SEE, if you’re using the log tool for the first time, after having clicked on 'Apply‘ (step 6), the MaximumFileSize value changes from “10MB” to 
“100MB”.



Backend Server

1- Stop the “SpeechExec Backend server” in Services by running services.msc
2- Open the following .config file: C:\Program Files (x86)\Philips Speech\SpeechExec Backend Server\SpeechExecLog.config
3- Edit the SpeechExecLog.config file with the Notepad
4- Replace the ERROR value by DEBUG from Edit> Replace… (select Match case)
5- File> Save
6- Re-launch the Backend server in Services
7- You can collect the SpeechExecBackEndServer.log from:
Win 32bit: C:\Windows\System32\config\systemprofile\AppData\Roaming\Philips Speech\SpeechExec\Logging
Win 64bit: C:\Windows\SysWOW64\config\systemprofile\AppData\Roaming\Philips Speech\SpeechExec\Logging



Enterprise License Server

1- Stop the “SpeechExec Enterprise License Server Service” in Services by running services.msc
2- Open the following .config file: C:\Program Files (x86)\Philips Speech\SpeechExec Enterprise License Server\SpeechExecLog.config
3- Edit the SpeechExecLog.config file with the Notepad
4- Replace the ERROR value by DEBUG from Edit> Replace… (select Match case)
5- File> Save
6- Re-launch the Enterprise License Server from Services
7- You can collect the PSP.SpeechExec.Enterprise.LicenseServer.log from:
Win 32bit: C:\Windows\System32\config\systemprofile\AppData\Roaming\Philips Speech\SpeechExec\Logging
Win 64bit: C:\Windows\SysWOW64\config\systemprofile\AppData\Roaming\Philips Speech\SpeechExec\Logging



Workflow Manager 

1- Stop the “SpeechExec Workflow Manager” in Services by running services.msc
2- Open the following .config file: C:\Program Files (x86)\Philips Speech\SpeechExec Workflow Manager\SpeechExecLog.config
3- Edit the SpeechExecLog.config file with the Notepad
4- Replace the ERROR value by DEBUG from Edit> Replace… (select Match case)
5- File> Save
6- Re-launch the Workflow Manager from Services
7- You can collect the PSP.SpeechExec.WorkflowManager.log from:
Win 32bit: C:\Windows\System32\config\systemprofile\AppData\Roaming\Philips Speech\SpeechExec\Logging
Win 64bit: C:\Windows\SysWOW64\config\systemprofile\AppData\Roaming\Philips Speech\SpeechExec\Logging



Philips Remote Device Manager: PRDM
1- To enable more detailed logging, under the following registry keys for the corresponding application, create a string value named 
“LogLevel”:
[HKEY_LOCAL_MACHINE\Software\Philips Speech\Remote Device Manager\Server]
[HKEY_LOCAL_MACHINE\Software\Philips Speech\Remote Device Manager\UpdaterClient]
[HKEY_LOCAL_MACHINE\Software\Philips Speech\Remote Device Manager\ManagementConsole]

2- On 64 bit Windows, please use “Software\Wow6432Node\” instead of “Software\”.

3- Enter one of the following values (choose DEBUG):

ERROR: only errors are logged, this is the default
WARN: errors and warnings are logged
INFO: errors, warning, and information messages are logged
DEBUG: everything is logged

4- The Management Console and the Updater Client save the log files to the following path:

Windows 7 and Windows Server 2008 R2 :
Users\<user name>\AppData\Local\Philips Remote Device Manager\UpdaterClient\log
Users\<user name>\AppData\Local\Philips Remote Device Manager\ManagementConsole\log
(click Start or go to the Windows 8 Search or at the Window’s Address bar, type %localappdata% and hit Enter)

The server saves the log files to the following path:

Windows 7 and Windows Server 2008 R2: 
Win 32bit: C:\Windows\System32\config\systemprofile\AppData\Local\Philips Remote Device Manager\Server\log
Win 64bit: C:\Windows\SysWOW64\config\systemprofile\AppData\Local\Philips Remote Device Manager\Server\log



Philips Device Control Center: PDCC

1- In Troubleshooter, click Logging to set the log level of the application. You have the following options (choose Detailed):
- Error only
- Info
- Detailed
2- When you change the log level, it immediately applies for the current session. To open the log folder in Windows Explorer, click 
Open (you can also access it manually by opening C:\Users\<user name>\AppData\Local\Philips Device Control Center\Log).
AppData: click Start or go to the Windows 8 Search or at the Window’s Address bar, type %localappdata% and hit Enter
Note: Detailed logging may decrease the performance of your computer as it requires considerably more disk space.



SWSDK: DPMCtrl, SpMikeCtrl
For DPMCtrl, SpMikeCtrl:
1- In the Logging folder \CD_SDK\SDK\Logging, you will find DPMCtrl.ini and SpMikeCtrl.ini. 
2- The storage location of the log file can be configured in the DPMCtrl.ini/ SpMikeCtrl.ini file, in our case is C:\temp\. Please be 
aware that the user has read and write permissions to the C:\temp\ folder as well as the DPMCtrl.ini/SpMikeCtrl.ini file have to be 
placed next to the DPMCtrl, SpMikeCtrl dll's (the COM Control dll ), which are used by our program or the integrators dll's.
3-Modify the content as follows:

DPMCtrl.ini:                                                                                     SpMikeCtrl.ini:

[LOGInitSettings]                                                                             [LOGInitSettings]
Enable=yes                                                                                       Enable=yes
File=C:\temp\DPMCtrl.log                                                             File=C:\temp\SpMikeCtrl.ini 
MaxLines=100000                                                                           MaxLines=100000
LogParams=no                                                                                 LogParams=no
LogComments=no                                                                           LogComments=no
LogVariables=no                                                                              LogVariables=no
Timeout=2000                                                                                 Timeout=2000
WrapAtMax=yes                                                                              WrapAtMax=yes
UseOutputDebug=no                                                                      UseOutputDebug=no
FilterFunctions=no                                                                           FilterFunctions=no
FilterVariables=no                                                                            FilterVariables=no
FilterComments=no                                                                         FilterComments=no

Connect the  Philips device and wait until the connected Philips USB device button presses do no longer arrive in the application.
Copy and save the log file, which is stored by default in C:\temp\DPMCtrl.log.
For SpeechExec SDK:
1- In the Logging folder, you can use the SpeechExecLogTool.exe file. Please refer to the page 6 since the settings are the same.
Note: The SpeechExecLog.Config file must be placed in the same folder where the integrator application (.exe) is situated and the 
output of the logging will also be written to this location.



Human Interface Device USB: PSPUSBLB
1- The storage location of the log file can be configured in the pspusblb.ini file, in our case is C:\temp\. Please be aware 
that the user has read and write permissions to the C:\temp\ folder.

2- Edit the existing pspusblb.ini file at: 
Win 32bit: C:\Windows\system32\PSPUSBLB.INI
Win 64bit: C:\Windows\SysWOW64\PSPUSBLB.INI

3-Modify the content as follows:

[LOGInitSettings]
Enable=yes
File=C:\temp\PSPUSBLB.log
MaxLines=100000
LogParams=no
LogComments=no
LogVariables=no
Timeout=2000
WrapAtMax=yes
UseOutputDebug=no
FilterFunctions=no
FilterVariables=no
FilterComments=no

Connect the  Philips device and wait until the connected Philips USB device button presses do no longer arrive in the 
application.
Copy and save the log file, which is stored by default in C:\temp\PSPUSBLB.log.



PSPDispatcher: WTS, Citrix, VMWare
1- The storage location of the log file can be configured in the PSPDispatcher.ini file, in our case is C:\temp\. Please be 
aware that the user has read and write permissions to the C:\temp\ folder (the “temp” folder is an example, created by 
us for this document. It doesn't exist by default under C:\).
2- Edit the existing PSPDispatcher.ini file at: 
Win 32bit: C:\Windows\system32\PSPDispatcher.INI
Win 64bit: C:\Windows\SysWOW64\PSPDispatcher.INI

3-Modify the content as follows:

[LOGInitSettings]
Enable=yes
File=C:\temp\PSPDispatcher.log
MaxLines=100000
LogParams=yes
LogComments=yes
LogVariables=yes
Timeout=2000
WrapAtMax=yes
UseOutputDebug=no
FilterFunctions=no
FilterVariables=no
FilterComments=no

Try to reconnect from the client to the server (virtual machine) and wait till the error occurs. 
Copy and save the log file, which is stored by default in C:\temp\PSPDispatcher.log.



MobileServer: Action Log, User Log
Action Log: In MobileServer, on the upper right side, click on “Show Logfile” and it will open the Action Log. Once the log file is 

open, click on File> Save As … and save it somewhere where you can access it later (necessary for most cases).

User Log: select a user from 1- Status Page> 2- User Information by Pin (select a user)> 3- Show log. Once the log file is open, click 

on File> Save As … and save it somewhere where you can access it later.



SpeechLive
Once connected to the SpeechLive as an admin, you can download the last activities under:

Workflow> User management> Download last activities, If Simple mode is selected

Workflow> Usage overview> Download last activities, If Advanced mode is selected

(you can change your view to different mode form Workflow> Switch administration mode> Switch to "X" mode)

After download, you’ll receive a .cvs file with all activities information.



Mac OS X: DPMConnect, SpeechControl
DPMConnect, SpeechControl
1- Close DPMConnect/SpeechControl (Quit DPMConnect/SpeechControl)
2- Open the info.plist under:
3- DPMConnect: Finder> Application> DPMConnect. Right click on DPMConnect then Show Package Contents> Contents> info.plist
4- SpeechControl: Finder> Application> SpeechControl. Right click on SpeechControl then Show Package Contents> Contents> info.plist
5- Add the following key at the end of the keys list, before  </dict></plist> and as follows (replace 4 by 0 to set the log to ERROR): 
<key>PSPLogLevel</key> 
<integer>4</integer>

Re-launch the DPMConnect/SpeechControl in order to reproduce the error
Collect the log files at Library> Application Support>DPMConnect/SpeechControl> Logs
How to access to Library folder? https://support.apple.com/kb/PH18928?locale=en_US&viewlocale=en_US

https://support.apple.com/kb/PH18928?locale=en_US&viewlocale=en_US


Mac OS X: SpeechExec for Mac
1- Open “Console” by typing “Console” on “Spotlight Search” or by opening Launchpad> Other> Console

2- In Console, right click on SpeechExec (Under FILES>  ~/Library/Logs) and choose “Reveal in Finder”. Once the folder is open, right 

click on SpeechExec folder and choose “Compress “SpeechExec””. 



MSInfo32.exe
1- Go to Start> Run > type "msinfo32.exe"
2- Select File> Save
3- Browse to an appropriate location to save the file
4- Type a filename into the appropriate field and ensure the "Save as type" is set to "System Information File (*.NFO)"
5- Click the "Save" button



Mac System Information:
1- On the top left side, click on Apple sign> About This Mac
2- Click on “System Report…”
3- On the top, choose File> Save…
4- Name the file as you wish and select the folder you would like to save the system information in “Where” and click on “Save” (in
our case, we chose “Desktop”)
5- Click the "Save" button



Please don’t forget to reset the log 
level from DEBUG to ERROR after 

troubleshooting. 




